Android P werkt niet met oudere Android-apps

Oudere Android-apps kunnen voor problemen zorgen op toestellen met Android P. De nieuwe Android-versie zal oudere applicaties niet langer meer ondersteunen. Dit blijkt uit nieuwe informatie uit de Developer Preview.

Oudere Android-apps in Android P

Android P werd eerder deze maand aangekondigd, direct met een Developer Preview. Hierin zaten een aantal nieuwe en tevens opvallende features. In de Developer Preview zijn nieuwe aanwijzingen gevonden voor veranderingen die zijn doorgevoerd, met betrekking op de compatibiliteit van applicaties.

Oudere Android-apps zullen niet langer meer ondersteund worden door Google in Android P. Ontwikkelaars dienen sinds enige tijd al rekening te houden met het ontwikkelen van apps met nieuwere Android-versies. Als Android P is uitgebracht, dienen de makers hun applicaties bijvoorbeeld geschikt te maken voor Android Oreo en hoger.

Android P oudere apps

In Android P zullen apps die zijn ontwikkeld voor Android 4.2 Jelly Bean niet langer meer ondersteund worden. Dit heeft bijvoorbeeld te maken met de bepaalde permissies en eisen die vastgesteld zijn in een nieuwe Android-versie. Android 6.0 Marshmallow bracht bijvoorbeeld Doze en verbeterde rechten. Een oudere app-versie kan dit omzeilen.

In de eerste Developer Preview waarin deze verandering is aangetroffen, wordt een melding getoond als een verouderde app wordt geopend. Het is hierbij niet duidelijk of het hier om een waarschuwing gaat of dat apps binnenkort ook daadwerkelijk geblokkeerd worden.

Via
Lees meer over:

Gerelateerd

Reageer op dit artikel